概要
カーテンモードを有効にした Screens を使用すると、Google Chrome がマウスクリックに反応しなくなることがあります。Safari、Finder、メールなどの他のアプリケーションは引き続き正常に動作します。
この問題は Screens に固有のものではなく、Apple Remote Desktop などの他のアプリでも再現される可能性があります。
原因
カーテンモードは、リモート Mac 上に 仮想ディスプレイ を作成し、それをクライアントアプリにストリーミングします。
Google Chrome は、AppKit に依存するネイティブ macOS アプリとは異なり、クロスプラットフォーム フレームワーク (Chromium/Skia) 上に構築されています。これらのフレームワークはレンダリングと入力の処理方法が異なるため、カーテンモードと組み合わせて使用するとクリックなどの操作が失敗する可能性があります。
影響を受けるアプリ
- Google Chrome
- macOS のネイティブフレームワークに依存しないその他のアプリ
macOS のネイティブアプリケーション(Safari、Finder、メール、システム環境設定など)と、ほとんどのサードパーティ製アプリは影響を受けません。
回避策
残念ながら、macOS のリモート管理には、この問題を解決するための設定はありません。
現時点での唯一の解決策は、Chrome を操作する際にカーテンモードを使用しないことです。カーテンモードを無効にすると、Chrome はマウスクリックに正常に反応します。
概要
- これは、カーテンモード使用時の Chrome の既知の制限です。
- これは Screens 自体の問題ではありません。
- 唯一の回避策は、Chrome を操作する際にカーテンモードを使用しないことです。