If you're experiencing issues with Remote Management or Screen Sharing on macOS — such as the connection stalling at "Connected", showing partial loading wheels, or requiring frequent toggling of settings to restore functionality — the steps below can help resolve deeper system-level problems that may be interfering with remote access.
These are advanced steps intended for users familiar with Terminal and system management. Proceed with caution, and make sure you have administrative access.
Symptoms This Article Addresses
- Remote Management or Screen Sharing intermittently stops responding
- You can see the remote Mac in Screens or macOS Screen Sharing, but connections freeze or fail
- Restarting Remote Management temporarily resolves the issue
- Logs show errors like screensharingd, Invalid credentials, or missing system files
Basic Fix
Start by turning Remote Management or Screen Sharing off and then back on. In many cases, this simple reset is enough to resolve the issue.
You’ll find step-by-step instructions in this article.
Advanced Fixes
1. Restart the Screen Sharing Daemon
Sometimes the screensharingd process gets stuck. Restarting it can restore functionality without needing to reset Remote Management entirely.
sudo pkill screensharingd
This command can be run from Terminal or via SSH, and the service will automatically restart.
2. Rebuild Remote Management Services
Resetting and restarting the macOS launch daemons for Remote Management and Screen Sharing may resolve hidden corruption or stalled states.
sudo launchctl bootout system /System/Library/LaunchDaemons/com.apple.screensharing.plist
sudo launchctl bootout system /System/Library/LaunchDaemons/com.apple.RemoteManagement.launchd
sudo launchctl bootstrap system /System/Library/LaunchDaemons/com.apple.screensharing.plist
sudo launchctl bootstrap system /System/Library/LaunchDaemons/com.apple.RemoteManagement.launchd
Then restart your Mac.
3. Recreate Missing System Files
In some cases, logs may show that macOS is missing critical system directories, such as:
/private/var/db/DetachedSignatures
To recreate this folder:
- Boot into macOS Recovery
- Open Terminal from the Utilities menu
- Run:
csrutil disable reboot
Once rebooted (back into regular macOS), open Terminal and run:
sudo mkdir -p /private/var/db/DetachedSignatures
sudo chmod 755 /private/var/db/DetachedSignatures
sudo chown root:wheel /private/var/db/DetachedSignatures
After creating the directory, you may re-enable System Integrity Protection (SIP) if desired:
csrutil enable
4. Fully Reset Remote Management Configuration
To wipe and reconfigure Remote Management from scratch:
sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart \
-deactivate -stop
sudo rm -f /Library/Preferences/com.apple.RemoteManagement.plist
sudo rm -rf /var/db/RemoteManagement
sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart \
-activate -configure -access -on -restart -agent -privs -all
Optional: Check for Viewer Session Overload
If your logs show messages like:
reset gMaxViewerConnection to 13
…it may mean the system isn’t cleaning up old VNC connections properly. You can use the pkill command (see Step 1) to regularly reset screensharingd, or consider scheduling it via launchd.
Safe Mode Test (Optional)
To rule out third-party interference:
- Restart your Mac
- Immediately hold Shift until the login screen appears
- Log in (you’ll be in Safe Mode)
- Enable Screen Sharing or Remote Management
- Try connecting from Screens
After Performing These Steps
- You should no longer need to toggle Remote Management off and on to restore access
- Screen Sharing connections should remain stable, even after long periods of uptime
- If issues return, capture logs immediately after a failure using:
log show --predicate 'process == "screensharingd"' --last 10m
Need Help?
If you’re still running into problems after trying the steps above, please contact us with a copy of your logs and details about your macOS version and network set-up.