Follow

Screens Connect Installation Issues

Screens Connect supports OS X 10.6.8 or later. To make sure you install the correct version, please download from https://screensconnect.com/d.

If you're having trouble installing the latest version, try rebooting your Mac first.

If you're still having trouble, and you're running OS X Yosemite or earlier, try repairing disk permissions. (Disk permissions are managed automatically by the operating system in El Capitan and later.)

Was this article helpful?
0 out of 1 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk